SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

Einführung in XHTML, CSS und Webdesign

Einführung in XHTML, CSS und Webdesign zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > PHP Grundlagen

PHP Grundlagen Hier kann über grundlegende Probleme oder Anfängerschwierigkeiten diskutiert werden

 
 
Themen-Optionen Ansicht
  #1  
Alt 18.08.2009, 13:04:38
guckers guckers ist offline
Anfänger
 
Registriert seit: Aug 2009
Alter: 70
Beiträge: 1
$_GET['id'] funktioniert nicht

Hallo,

bei mir funktioniert in PHP5 die Funktion $_GET nicht.

Ich hoffe mir kann einer helfen.
Folgende Situation:

Ich übergebe mit dem LINK auf die nächste Seite, hier >hilfe.php<, eine Variable.
Der Wert, den ich übergeben möchte, geht auch mit dem Aufruf der nächsten Seite weiter.
Das ist mein PHP-Code:
PHP-Code:
<?php
....
.....
.....
echo 
"<a href=\"hilfs.php?id=".$teilVerzeichnis." \"targe.........;
.....
.....
.....
?>
Es erscheint:
http://........./hilfs.php?id= und der Wert aus der Variablen "$teilVerzeichnis.

Rufe ich nun in der aktivierten Seite >hilfs.php< den Code:
PHP-Code:
<?php
error_reporting
(E_ALL);
echo 
$_GET["id"];
?>
auf, so bekomme ich die Mitteilung:
Notice: Undefined index: id in C:\SC-Eitweg\html\hilfs.php on line 22.

line 22 = echo $_GET["id"];

was mach ich falsch?

mfG
guckers
Mit Zitat antworten
 


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Bild als Blob in DB - Ausgabe funktioniert nicht ceptar PHP Grundlagen 6 19.02.2006 17:15:33
Bildupload funktioniert lokal, online aber nicht 8805-evergreen. PHP Grundlagen 11 09.02.2006 14:55:48
TXT-Datei splitten, funktioniert nicht mit Leerstellen BenjaminG PHP Grundlagen 11 29.06.2005 16:08:04
Eintrag aus DB lesen - funktioniert nur teilweise exweised PHP Grundlagen 4 07.09.2004 11:04:25
prüfen unter welcher Endung PHP funktioniert... FourSix Off Topic Area 4 10.04.2003 22:37:28


Alle Zeitangaben in WEZ +2. Es ist jetzt 08:30:52 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.


© 2001-2024 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt