SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

PHP 5.3 & MySQL 5.1

PHP 5.3 & MySQL 5.1 zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > Off Topic Area

Off Topic Area Hierein gehört alles, was nichts mit PHP, MySQL, Apache oder ähnlichem zu tun hat

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 26.07.2003, 19:56:48
Ben20
Guest
 
Beiträge: n/a
./configure --with-nix?

Hallo Leute,

ich versuche ja jetzt schon seit längerem :( PHP auf meinem Server von der Modulversion in die CGI Version zuzubauen. Bisher mit wenig Erfolg. Immerhin hab ich es jetzt schon geschafft PHP zu installieren, allerdings nur mit ./configure (ohne irgendwelche Parameter) sobald ich ein paar Parameter hinzfüge klappt das "make" nicht mehr. Nun zu meinen Fragen:

1. Was sollte unbedingt ins ./configure
2. Wie bekomme ich die GD ans laufen (Ich bekomm mal wieder so eine lustige, benutzerfreundliche und vorallem viel informativere Fehlermeldung als bei Windows (gd_png.h not found) - Wer Ironie findet darf sie behalten!)
3. Wer hilft mir dem durschnittlichen Programmierer die bedeutung des Wortes "Usability" beizubringen!

Danke!
Mit Zitat antworten
  #2  
Alt 27.07.2003, 19:24:41
Damir Damir ist offline
Administrator
 
Registriert seit: Jan 2002
Ort: Köln
Alter: 51
Beiträge: 1.276
Hi Ben20,
und ich dachte der Server waere schon total aufgemotzt ;-))
Naja, eigentlich ist die Installation unter Linux leicht - man sollte um nicht den Ueberblick zu verlieren, vieleicht klein anfangen (also nicht den kompletten configure-Befehl).
In der Regel sind aber die Fehlermeldungen sehr gut und man weiss sehr schnell was man noch machen muss.
Wichtig ist allerdings, dass benoetigte Libraries installiert sind und im configure-Befehl die Verpfadung zu diesen Libraries korrekt angegeben wird. Falls Du die Verpfadung, ausgehend vom make-Befehl, nicht genau deklarieren kannst, so versuche es einfach mit einer absoluten Verpfadung vom root ausgehend.
Fuer GD ist aber zlib, libjpeg und freetype zu empfehlen und sollte installiert werden.
Da es einfacher ist einen Link zu posten als alles neu zu schreiben:
http://www.baach.de/
Das sollte eigentlich helfen.

Bye Damir

P.S.
Bekommst Du hier auch schon einen Fehler, sobald Du MySQL einbindest????

./configure --with-mysql=/usr
Mit Zitat antworten
  #3  
Alt 27.07.2003, 23:29:21
Ben20
Guest
 
Beiträge: n/a
Hi,

ich vermute es hängt an der GD Lib, die kann ich nämlich nicht kompilieren. (lib_png not found - obwohl eine Lippng per RPM reininstalliert ist).

Auf www.baach.de war ich schon, ohne Erfolg! Da hat Linux mal wieder die Schlacht gewonnen, aber den Krieg noch lange nicht ;-) - ich werds demnächst nochmal versuchen!

BTW: Ich bin ja eigentlich kein Winzigweich Fan, aber man muss ihnen lassen das die Installtion von PHP auf Win wesentlich (!!!) einfacher geht (Klick - läuft!) warum gibts sowas nicht für Linux?
Mit Zitat antworten
  #4  
Alt 28.07.2003, 00:31:16
Damir Damir ist offline
Administrator
 
Registriert seit: Jan 2002
Ort: Köln
Alter: 51
Beiträge: 1.276
Hi,
ja dann installiere doch nochmal die lib_png - vieleicht wurde diese ja nicht vernuenftig installiert;-))
Oftsmals ist es halt ein ausprobieren und lesen aber in der REgel laeuft es dann relativ schnell......


Zitat:
BTW: Ich bin ja eigentlich kein Winzigweich Fan, aber man muss ihnen lassen das die Installtion von PHP auf Win wesentlich (!!!) einfacher geht (Klick - läuft!) warum gibts sowas nicht für Linux?
Weil man Dir volle Entscheidungsfreiheit laesst........
Dafuer sind die Winzigweich-Fans gefangen in ihrem System;-))
Unter Linux steht Dir die Welt offen:-))

Bye Damir
Mit Zitat antworten
  #5  
Alt 28.07.2003, 00:36:02
Ben20
Guest
 
Beiträge: n/a
Ok, dann bügel ich nochmal die Lib PNG drüber!


P.S.


Zitat:
Dafuer sind die Winzigweich-Fans gefangen in ihrem System;-)) Unter Linux steht Dir die Welt offen:-))

Hm, theoretisch stehts mir auch frei nach Amerika zu schwimmen, aber da hab ichs doch lieber wenn ich weniger frei (dafür trocken und vorallem lebenden) mit nem Schiff fahre! Ist was dran, oder? ;-)
Mit Zitat antworten
  #6  
Alt 28.07.2003, 10:35:18
Damir Damir ist offline
Administrator
 
Registriert seit: Jan 2002
Ort: Köln
Alter: 51
Beiträge: 1.276
Zitat:
Hm, theoretisch stehts mir auch frei nach Amerika zu schwimmen, aber da hab ichs doch lieber wenn ich weniger frei (dafür trocken und vorallem lebenden) mit nem Schiff fahre! Ist was dran, oder? ;-)
Ja ist was dran - ein Linux-User wuerde aber dann fliegen ;-))

Bye Damir
Mit Zitat antworten
  #7  
Alt 28.07.2003, 10:48:46
Ben20
Guest
 
Beiträge: n/a
Also ich hab jetzt versucht die libpng nochmal neu drüber zu äh rpm'en? bekomme aber nur die Meldung dass dieses nicht geht weil da Abhänigkeiten bestehen. Bei der Gelegenheit ist mir aufgefallen, dass da wohl schon ne GD 1.8.x drauf ist. Ich muss die jetzt bei nächster Gelegenheit suchen und PHP bei der Configuration mal den Pfad mit geben. Was ich auch noch gesehen habe, ist, dass mein Hoster (der den Server zum 1. mal eingerichtet hat) PHP mit Hilfe von rpm installiert hat (wenn auch nicht als CGI) - das ist ja praktisch! Ich hab daraufhin mal bei rpmfind.net geschaut - da gibts sogar PHP 4.3.2 als RPM. Wenn ichs per Hand nicht hinbekomme, werd ich mal die RPM ausprobieren, das müsste ja ne CGI Version sein, Module gibts doch nur bis 4.1.x, oder?


And the saga continues ;-)
Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +2. Es ist jetzt 00:17:39 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.


© 2001-2023 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt