SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

Der CSS-Problemlöser

Der CSS-Problemlöser zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > PHP Grundlagen

PHP Grundlagen Hier kann über grundlegende Probleme oder Anfängerschwierigkeiten diskutiert werden

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 29.04.2008, 11:59:01
belanglos belanglos ist offline
Anfänger
 
Registriert seit: Feb 2008
Beiträge: 5
Problem mit dem Login seit Serverwechsel

Hallo,

ich habe ein kleines Problem. Ich bin mit einer Seite von einem "normalen" Webspace auf einen Server umgezogen. Es hat auch soweit alles geklappt (hochladen, einrichten, Datenbank usw.). Ich habe jetzt nur das Problem, daß wenn ich mich einlogge, ich mich zwar auch einlogge, aber mir wird nur angezeigt "Guten Tag LEER". Da wo LEER steht, müsste eigentlich der Loginname stehen. Also es scheint, als würde es ein Problem mit dem einloggen oder der Session geben.

Da ich jetzt jetzt nur absolute Grund- oder besser gesagt Anfängerkenntnisse habe, wollte ich mal fragen, ob mir jemand von euch sagen kann, wo ich mit der Fehlersuche anfange und nach was für einen Fehler ich suchen muss.

Dafür schon mal eine fettes Danke!

Gruß
Mit Zitat antworten
  #2  
Alt 29.04.2008, 15:19:09
Benutzerbild von Domi
Domi Domi ist offline
Senior Member
 
Registriert seit: Nov 2003
Ort: Kempten @ Allgäu
Alter: 36
Beiträge: 1.408
AW: Problem mit dem Login seit Serverwechsel

poste uns doch mal nen bisschen Code, in PHP-Tags natürlich.

Schau dir bitte auch die Fehler an die

PHP-Code:
error_reporting(E_ALL E_STRICT); 
ausgibt

Sieht jetzt mal so aus, als hättest du Probleme mit den Superglobalen... Stichwort: register_globals

greeTz
Domi
__________________

the best way to be ready for the future is to invent it
Mit Zitat antworten
  #3  
Alt 29.04.2008, 16:12:56
Calvados Calvados ist offline
Anfänger
 
Registriert seit: Nov 2007
Beiträge: 27
AW: Problem mit dem Login seit Serverwechsel

Hallo,

poste doch mal den PHP-Code der Seite, die nach dem Loginformular aufgerufen wird...

Grüsse
Calvados
Mit Zitat antworten
  #4  
Alt 29.04.2008, 17:52:27
belanglos belanglos ist offline
Anfänger
 
Registriert seit: Feb 2008
Beiträge: 5
AW: Problem mit dem Login seit Serverwechsel

Zitat:
Zitat von Domi Beitrag anzeigen

Schau dir bitte auch die Fehler an die

PHP-Code:
error_reporting(E_ALL E_STRICT); 
Wo finde ich das?

Zitat:
Zitat von Calvados Beitrag anzeigen
Hallo,

poste doch mal den PHP-Code der Seite, die nach dem Loginformular aufgerufen wird...

Grüsse
Calvados
Den PHP-Code, der benutzt wird um sich einzuloggen?
Mit Zitat antworten
  #5  
Alt 29.04.2008, 18:10:03
Benutzerbild von Domi
Domi Domi ist offline
Senior Member
 
Registriert seit: Nov 2003
Ort: Kempten @ Allgäu
Alter: 36
Beiträge: 1.408
AW: Problem mit dem Login seit Serverwechsel

na du gibst gleich zu Beginn deines Scripts ein:

error_reporting(E_ALL | E_STRICT);

also nach "<?php" dann werden die alle Fehler ausgegeben. Damit wir dir helfen können musst du uns auch dein PHP Script zeigen, an welches das Formular geschickt wird.

Domi
__________________

the best way to be ready for the future is to invent it
Mit Zitat antworten
  #6  
Alt 29.04.2008, 18:20:41
belanglos belanglos ist offline
Anfänger
 
Registriert seit: Feb 2008
Beiträge: 5
AW: Problem mit dem Login seit Serverwechsel

Ich habe jetzt mal ein wenig weiter getestet (nach dem Hinweis von Domi). Es scheint an register_globals zu liegen. Seit ich die auf "on" gestellt habe, funktioniert es wieder. Was müsste ich denn dann im CODE abändern, damit ich register_globals off lassen kann und mich normal einloggen kann?
Mit Zitat antworten
  #7  
Alt 29.04.2008, 19:30:21
Benutzerbild von Domi
Domi Domi ist offline
Senior Member
 
Registriert seit: Nov 2003
Ort: Kempten @ Allgäu
Alter: 36
Beiträge: 1.408
AW: Problem mit dem Login seit Serverwechsel

du verwendest die globalen Variablen $_POST und $_GET

alles was per Formular kommt steht normalerweise in $_POST und was in der URL angehängt wird (z.B. index.php?test=hallo) steht im Array $_GET. Darauf könntest du jetzt zugreifen mit $_GET['test'] und rauskommen würde "hallo".

mit print_r($_POST); kannst du dir einfach mal das ganze Array anzeigen lassen.

Domi
__________________

the best way to be ready for the future is to invent it
Mit Zitat antworten
  #8  
Alt 30.04.2008, 23:50:58
Calvados Calvados ist offline
Anfänger
 
Registriert seit: Nov 2007
Beiträge: 27
AW: Problem mit dem Login seit Serverwechsel

Hallo,

Mit anderen Worten, du musst wohl

if($user != "")

ändern in

if($_POST['user'] != "")

...um mal ein Beispiel zu nennen.

Allerdings ist es nicht immer einfach herauszufinden, ob ein $_POST oder $_GET
Array, oder ob im Einzelfall ein $_REQUEST Array, verwendet werden muss...

Die register_globals auf ON zu lassen, würde ich aus Sicherheitsgründen nicht empfehlen.
Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Sessions nach Serverwechsel Thomapyrien PHP Grundlagen 4 10.01.2006 15:41:18
Problem: Login Script v1.0(MySQL) funktioniert nicht Discoverer PHP Grundlagen 6 09.05.2005 13:20:22
Problem bei LogIn in AdminBereich Blue7 MySQLi/PDO/(MySQL) 0 20.02.2004 18:31:50
Problem mit LOGIN DeMarcus PHP für Fortgeschrittene und Experten 1 11.02.2003 11:04:13
Problem mit Variablenübergabe nach Serverwechsel egon2000 PHP für Fortgeschrittene und Experten 2 01.09.2002 14:57:45


Alle Zeitangaben in WEZ +2. Es ist jetzt 12:07:15 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.


© 2001-2024 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt