PHP Forum

PHP Forum (http://www.selfphp.de/forum/index.php)
-   Apache HTTP-Server (http://www.selfphp.de/forum/forumdisplay.php?f=23)
-   -   Wie Sperre ich eine Bestimmte Browser Version aus? (http://www.selfphp.de/forum/showthread.php?t=26038)

Rolfi001 06.08.2017 21:22:19

Wie Sperre ich eine Bestimmte Browser Version aus?
 
Hallo,

vielleicht kann mir hier jemand helfen.
Ich habe einen Webserver, und ich habe auf mehreren Web's das Problem das ein Bestimmter Browser Typ sich
in Wordpress oder Joomla Seiten einzuloggen versucht mit verschiedenen IP-Adressen.
Der Browser den ich meine ist Firefox 40.1

Wie kann ich diese Browserversion komplett für alle Sperren?

Ich weis auch das der Angreifer die Versionsnummer Ändern kann, ich möchte ja nur kurzzeitig ruhe haben damit ich weitere Maßnahmen durchführen kann ohne das der Webserver in die knie geht.

ich habe zur Zeit folgendes Installiert.

Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-83-generic x86_64)
Apache/2.2


Für jede Hilfe wäre ich dankbar!

MfG

Rolfi

sysop 07.08.2017 10:40:52

AW: Wie Sperre ich eine Bestimmte Browser Version aus?
 
Die Abfrage von
PHP-Code:

$_SERVER['HTTP_USER_AGENT'

könnte ein Lösungsansatz sein, allerdings lässt sich die Browserkennung problemlos faken.

Unter Linux wäre aber auf deinem Server fail2ban eher das Tool, das du suchst und das dir Ruhe verschaffen kann.

Wordpress und Jomla werden wohl auch Plugins zur Bekämpfung von fehlerhaften Login (Hack) Versuchen zur Verfügung stellen. Die haben dann den Vorteil, dass sie selbst erkennen dass da etwas im Argen liegt.


Alle Zeitangaben in WEZ +2. Es ist jetzt 21:59:15 Uhr.

Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.