SELFPHP: Version 5.8.1 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche


International PHP Conference


WebTech Conference



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



PHP Summit


Software Architecture Summit


:: Buchempfehlung ::

PHP 5.3 & MySQL 5.1

PHP 5.3 & MySQL 5.1 zur Buchempfehlung
 
HTML5 Days


JavaScript Days


:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Deine Leidenschaft ist die Unterwasserfoto-grafie?


Dann ist Qozido genau das Richtige für Dich!

Die Bilderverwaltung mit Logbuch für Taucher und Schnorchler ist da!

www.qozido.de

 


Zurück   PHP Forum > SELFPHP > Apache HTTP-Server

Apache HTTP-Server Alles was Ihr über den Apache diskutieren möchtet, gehört hierein

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 19.11.2003, 20:48:30
JPohlmann JPohlmann ist offline
Anfänger
 
Registriert seit: Nov 2003
Beiträge: 2
JPohlmann befindet sich auf einem aufstrebenden Ast
Apache 2.0.4.7 - Problem mit PHP-Variablenübergabe

Mein Problem ist das folgende:
Wenn ich per Link - z.B. href="beliebigeseite.php?variable1=x" - eine PHP-Variable übergeben will, wird diese auf der nachfolgenden Seite nicht unter dem Variablennamen $variable1 erkannt.
Mit Apache 1.3.9/1.3.26 und PHP 4.2.1 hatte ich noch keine Probleme, aber seit ich aus diversen Gründen Apache 2.0.47 in Kombination mit PHP 4.3.3 verwende, funktioniert diese elementare Vorgehensweise nicht mehr. Ich muss die Variable nun mit $_GET["variable1"] aufrufen.

Kann mir hier vielleicht jemand weiterhelfen, ist dieses Problem bekannt oder ist das am Ende sogar von den Entwicklern so beabsichtigt?

Wenn noch nähere Angaben erforderlich sind, teile ich diese gerne mit.
Mit Zitat antworten
  #2  
Alt 19.11.2003, 21:02:51
sourcecode sourcecode ist offline
Junior Member
 
Registriert seit: May 2003
Beiträge: 258
sourcecode befindet sich auf einem aufstrebenden Ast
Zitat:
original von c4:

Standardposting:
Mit Version 4.1 wurde in PHP ein neues Sicherheitskonzept eingeführt, welches seit Version 4.2 standardmäßig aktiviert ist. Seit dem muss man alle übergebenen Variablen mit
$_GET['variable'] - für Urlparameter
$_POST['variable'] - für mit method=post versendete Parameter
$_COOKIE['variable'] - für Cookies
$_REQUEST['variable'] - $_POST, $_GET und $_COOKIE zusammen
$_FILES['variable'] - für hochgeladene Dateien
$_SERVER['variable'] - für Servervariablen (z.B. $_SERVER['PHP_SELF'])
$_ENV['variable'] - für Umgebungsvariablen
ansprechen. Also ehemals $str mit $_GET['str']
Oder Du setzt in der php.ini register_globals auf on. Davon rate ich aber ab.
Es ist also beabsichtigt. Wenn du dein Skript nicht ordentlich schreibst, kann ein Angreifer sonst an Daten rankommen, die nicht für ihn bestimmt sind.
Mit Zitat antworten
  #3  
Alt 19.11.2003, 21:14:04
JPohlmann JPohlmann ist offline
Anfänger
 
Registriert seit: Nov 2003
Beiträge: 2
JPohlmann befindet sich auf einem aufstrebenden Ast
Alles klar, danke für die schnelle Antwort.
Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +2. Es ist jetzt 08:59:55 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.


© 2001-2014 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt