SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

Webseiten professionell erstellen

Webseiten professionell erstellen zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > MySQL/MySQLi

MySQL/MySQLi Anfänger, Fortgeschrittene oder Experten können hier Fragen und Probleme rund um MySQL/MySQLi diskutieren

 
 
Themen-Optionen Ansicht
  #1  
Alt 29.06.2017, 16:51:03
kraibi kraibi ist offline
Anfänger
 
Registriert seit: Jun 2017
Alter: 53
Beiträge: 2
mySQL Abfrage funktioniert plötzlich nicht mehr

Hallo!

Vielleicht kann mir hier jemand helfen.

In meiner Datenbank (PHP-mySQL) habe ich seit Jahren eine Abfrage die immer funktioniert hat.
Ich habe an der DB nichts geändert, aber seit heute kommt eine "0" statt dem richtigen Ergebnis.

Hier die Abfrage:

Zitat:
SELECT COUNT(*) AS anzahl FROM teststellung t INNER JOIN (SELECT MAX(b.tID) AS maxID FROM teststellung b GROUP BY b.tnummer) AS c ON c.maxID = t.tID WHERE t.tnummer NOT IN (SELECT x.tnummer FROM teststellung x WHERE x.tstatus = 0) AND t.tnummer > 0 ORDER BY t.tnummer

Zur Erklärung: Ich habe eine Tabelle in der "Teststellungen" tID angelegt werden. Den "Teststellungen" werden dann eine "Musterware" tnummer zugeordnet. Die Musterware kann mehrmals einer Teststellung zugeordnet werden. Bis es die Musterware nicht mehr gibt. Das ist dann am tstatus ersichtlich.

Mit der Abfrage Zähle ich, wie viele Muster es tatsächlich noch gibt. Es kam bis gestern immer das richtige Ergebnis raus. Seit heute "0".

Übrigens: Wenn ich die "NOT IN" Klausel raus nehme, kommt ein Wert raus, der allerdings nicht stimmt.

Es sind übgrigens fast 6000 Datensätze in der Tabelle. Die Abfrage dauern entsprechend lange, ca. 13 Sekunden.

Wenn hier jemand einen Tipp hat, wäre ich echt froh.

Beste Grüße
Günther
Mit Zitat antworten
 


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
PHP for $i und MySQL Abfrage wha MySQL/MySQLi 2 27.11.2013 22:27:55
MySQL - Filmdatenbank - Filmtitel/Darsteller Abfrage loddoking MySQL/MySQLi 30 24.09.2013 13:55:57
MYSQL Verschachtelte Abfrage mit Replace - wer kann helfen??? supermoto MySQL/MySQLi 7 25.07.2013 10:44:23
Problem bei MySQL Abfrage mit Datum tram1 PHP Grundlagen 2 03.05.2013 16:21:34
MySQL Abfrage der letzten 6 Monate Andy PHP für Fortgeschrittene und Experten 3 19.02.2002 00:05:46


Alle Zeitangaben in WEZ +2. Es ist jetzt 20:54:28 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.


© 2001-2020 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt