SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

Der CSS-Problemlöser

Der CSS-Problemlöser zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > PHP für Fortgeschrittene und Experten

PHP für Fortgeschrittene und Experten Fortgeschrittene und Experten können hier über ihre Probleme und Bedenken talken

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 22.11.2007, 12:40:57
teamore teamore ist offline
Anfänger
 
Registriert seit: Nov 2007
Ort: Berlin
Alter: 46
Beiträge: 17
teamore eine Nachricht über ICQ schicken teamore eine Nachricht über Yahoo! schicken teamore eine Nachricht über Skype™ schicken
Problem mit ini_set

Moin,

ich möchte den include_path von php während der laufzeit eines skripts ändern. das funktioniert sonst wunderbar, aber leider hat ini_set im vorliegenden fall überhaupt keine wirkung!

Dieses Skript:
PHP-Code:
$incpath ini_get("include_path").PATH_SEPARATOR."/test/";
echo 
ini_get("include_path")."<br />";
echo 
"setting include_path ($incpath)<br />";
$r ini_set("include_path",$incpath);
echo 
"result: [ $r ]<br />";
echo 
ini_get("include_path")."<br />"
erzeugt folgende Ausgabe:
Zitat:
.:/usr/share/php5:/usr/share/php:
setting include_path (.:/usr/share/php5:/usr/share/php::/test/)
result: [ ]
.:/usr/share/php5:/usr/share/php:
wie also unschwer zu erkennen ist, hat ini_set keinerlei auswirkung auf die "include_path"-direktive und meine skripte werfen demnach auch reihenweise include-fehler..

auch andere php_umgebungsvariablen kann ich nur über apache steuern, über ini_set aber nicht setzen, und set_include_path funktioniert ebenfalls nicht.

php läuft als CLI und es handelt sich um einen root-server, d.h. ich habe zugriff auf alle servervariablen.

in der php-ini habe ich nichts gefunden, was auf eine deaktivierung von ini_set schließen ließe..

hat jemand einen tip?

cheerio aus berlin.
teaMore
Mit Zitat antworten
  #2  
Alt 22.11.2007, 13:07:09
Benutzerbild von vt1816
vt1816 vt1816 ist offline
Administrator
 
Registriert seit: Jul 2004
Beiträge: 3.703
AW: Problem mit ini_set

Willkommen im Forum!

register global = off!
__________________
Gruss vt1816
Erwarte nicht, dass sich jemand mehr Mühe mit der Antwort gibt als Du Dir mit der Frage.
. . . . . Feedback wäre wünschenswert

Ich werde keinen privaten 1:1 Support leisten, außer ich biete ihn ausdrücklich an.
Ansosnten gilt: Hilfe ausserhalb dieses Thread (PN, WhatsApp, Skype, Mail, ICQ, etc...) nur per Barzahlung oder Vorauskasse!

Wenn man sich selbst als "Noob" bezeichnet, sollte man die Finger davon lassen.
Wenn man gewillt ist daran etwas zu ändern, lernt man Grundlagen!
Mit Zitat antworten
  #3  
Alt 22.11.2007, 14:10:52
teamore teamore ist offline
Anfänger
 
Registriert seit: Nov 2007
Ort: Berlin
Alter: 46
Beiträge: 17
teamore eine Nachricht über ICQ schicken teamore eine Nachricht über Yahoo! schicken teamore eine Nachricht über Skype™ schicken
AW: Problem mit ini_set

danke für die antwort und die willkommensgrüße :)

wie meinste "register_globals = off" ?

hab nichts an der register_globals - direktive geändert, d.h. register_globals ist (gemäß der php5-voreinstellung) auf "off".

cheers. tea
Mit Zitat antworten
  #4  
Alt 22.11.2007, 14:18:25
rambi
Guest
 
Beiträge: n/a
AW: Problem mit ini_set

PHP-Code:
error_reporting(E_ALL);
ini_set('display_errors',1);

$incpath   explode(PATH_SEPARATOR,ini_get('include_path'));
$incpath[] = './test';
ini_set('include_path',implode(PATH_SEPARATOR,$incpath)); 

Geändert von rambi (22.11.2007 um 14:18:44 Uhr)
Mit Zitat antworten
  #5  
Alt 22.11.2007, 15:11:23
Benutzerbild von vt1816
vt1816 vt1816 ist offline
Administrator
 
Registriert seit: Jul 2004
Beiträge: 3.703
AW: Problem mit ini_set

Zitat:
Zitat von teamore Beitrag anzeigen
danke für die antwort und die willkommensgrüße :)

wie meinste "register_globals = off" ?

hab nichts an der register_globals - direktive geändert, d.h. register_globals ist (gemäß der php5-voreinstellung) auf "off".

cheers. tea
Nicht alle Werte lassen bei "register_globals = off" auch ändern/überschreiben.
__________________
Gruss vt1816
Erwarte nicht, dass sich jemand mehr Mühe mit der Antwort gibt als Du Dir mit der Frage.
. . . . . Feedback wäre wünschenswert

Ich werde keinen privaten 1:1 Support leisten, außer ich biete ihn ausdrücklich an.
Ansosnten gilt: Hilfe ausserhalb dieses Thread (PN, WhatsApp, Skype, Mail, ICQ, etc...) nur per Barzahlung oder Vorauskasse!

Wenn man sich selbst als "Noob" bezeichnet, sollte man die Finger davon lassen.
Wenn man gewillt ist daran etwas zu ändern, lernt man Grundlagen!
Mit Zitat antworten
  #6  
Alt 22.11.2007, 15:17:12
rambi
Guest
 
Beiträge: n/a
AW: Problem mit ini_set

Zitat:
Nicht alle Werte lassen bei "register_globals = off" auch ändern/überschreiben.
Echt? Welche?

Nicht alle Parameter lassen sich per ini_set() setzen!! Wohl war!
Aber, was soll register_globals damit zu tun haben....?

Geändert von rambi (22.11.2007 um 15:19:21 Uhr)
Mit Zitat antworten
  #7  
Alt 22.11.2007, 15:29:58
teamore teamore ist offline
Anfänger
 
Registriert seit: Nov 2007
Ort: Berlin
Alter: 46
Beiträge: 17
teamore eine Nachricht über ICQ schicken teamore eine Nachricht über Yahoo! schicken teamore eine Nachricht über Skype™ schicken
AW: Problem mit ini_set

@vt1816: ich höre zum ersten mal, dass register_globals irgendeine auswirkung auf die funktion von ini_set hat.. das kann ich mir nicht vorstellen, und eine änderung auf register_globals = 1 über die apache-conf hat auch keinerlei auswirkung auf das problem.

@rambi: thx, aber das ist ja im prinzip nur ne andere syntax für dieselbe operation. das ändern der include_pfade funktioniert erwartungsgemäß auch mit dieser variante nicht.

ich kann den include_path zwar ebenfalls über die apache-conf setzen, aber das ist ja nicht zweck der übung, weil die pfadressourcen für meine webapplikation über eine xml-datei eingelesen werden, damit ich die include_paths über die webapplikation steuern kann, um die portabilität gewährleisten zu können.

also nochmal im klartext mein problem: ich kann mit ini_set() keine einzige php_umgebungsvariable setzen, sondern nur über die apache-conf.

ini_set liefert also keine fehlermeldung zurück, sondern ein "false", und die umgebungsvariable bleibt unangetastet, ohne das php irgendeinen fehler zurückwirft.

woran kann das liegen?
Mit Zitat antworten
  #8  
Alt 22.11.2007, 15:40:34
teamore teamore ist offline
Anfänger
 
Registriert seit: Nov 2007
Ort: Berlin
Alter: 46
Beiträge: 17
teamore eine Nachricht über ICQ schicken teamore eine Nachricht über Yahoo! schicken teamore eine Nachricht über Skype™ schicken
AW: Problem mit ini_set

hier noch der vollständigkeit halber die phpinfo:

http://pulsarv3.h1154004.serverkompe...ublic/info.php
Mit Zitat antworten
  #9  
Alt 22.11.2007, 15:59:53
defabricator defabricator ist offline
Senior Member
 
Registriert seit: Sep 2007
Ort: Potsdam
Alter: 53
Beiträge: 1.020
AW: Problem mit ini_set

Dann bitte mal die Ausgabe von
PHP-Code:
<?php
echo '<pre>';
var_dump(error_reporting(E_ALL));
var_dump(ini_set('display_errors'1));
var_dump(ini_set('track_errors'1));
var_dump($php_errormsg);
var_dump(ini_set('include_path''abc'));
var_dump(ini_set('include_path''xyz'));
var_dump($php_errormsg);
echo 
'</pre>';
posten.
__________________
Wat der Bauer nich kennt, dit frisster nich.
Mit Zitat antworten
  #10  
Alt 22.11.2007, 16:06:54
teamore teamore ist offline
Anfänger
 
Registriert seit: Nov 2007
Ort: Berlin
Alter: 46
Beiträge: 17
teamore eine Nachricht über ICQ schicken teamore eine Nachricht über Yahoo! schicken teamore eine Nachricht über Skype™ schicken
AW: Problem mit ini_set

hey defabric!

hier die ausgabe:

int(6135)
string(1) "1"
string(0) ""


Notice: Undefined variable: php_errormsg in /var/www/pulsar-records.de/public_html/pulsar/public/config.php on line 6

NULL
bool(false)
bool(false)
string(32) "Undefined variable: php_errormsg"
Mit Zitat antworten
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
animation problem Indyk HTML, CSS und JavaScript Help! 7 27.09.2006 09:39:03
Problem mir FPDF (genauer HTML2FPDF) Spark PHP für Fortgeschrittene und Experten 0 24.02.2006 10:06:02
Problem mit Lokalisierung eines SESSION - Problems Fabian85 PHP für Fortgeschrittene und Experten 5 03.10.2005 21:17:54
mysql und php problem schmidt PHP für Fortgeschrittene und Experten 9 31.10.2003 19:05:13
SSL Problem im Internet Explorer, need help! Gladder PHP für Fortgeschrittene und Experten 6 02.09.2002 23:21:19


Alle Zeitangaben in WEZ +2. Es ist jetzt 11:54:22 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.


© 2001-2023 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt