SELFPHP: Version 5.8.2 Befehlsreferenz - Tutorial – Kochbuch – Forum für PHP Einsteiger und professionelle Entwickler

SELFPHP


Professional CronJob-Service

Suche



CronJob-Service    
bei SELFPHP mit ...



 + minütlichen Aufrufen
 + eigenem Crontab Eintrag
 + unbegrenzten CronJobs
 + Statistiken
 + Beispielaufrufen
 + Control-Bereich

Führen Sie mit den CronJobs von SELFPHP zeitgesteuert Programme auf Ihrem Server aus. Weitere Infos



:: Buchempfehlung ::

TYPO3 Kochbuch

TYPO3 Kochbuch zur Buchempfehlung
 

:: Anbieterverzeichnis ::

Globale Branchen

Informieren Sie sich über ausgewählte Unternehmen im Anbieterverzeichnis von SELFPHP  

 

:: Newsletter ::

Abonnieren Sie hier den kostenlosen SELFPHP Newsletter!

Vorname: 
Name:
E-Mail:
 
 

Zurück   PHP Forum > SELFPHP > Apache HTTP-Server

Apache HTTP-Server Alles was Ihr über den Apache diskutieren möchtet, gehört hierein

 
 
Themen-Optionen Ansicht
  #1  
Alt 25.11.2009, 20:02:59
SargTeX SargTeX ist offline
Anfänger
 
Registriert seit: Nov 2009
Alter: 26
Beiträge: 3
Installationsprobleme

Moin.

Versuche nun schon seit über 24h, Apache V 2.2.14 zu installieren. Sollte eigentlich kein Problem darstellen, da ich es unter Windows schon häufiger installiert und deinstalliert habe- mit PHP und MySQL.

Ich verwende nun als Betriebssystem Ubuntu 9.10 Netbook Remix auf einem Toshiba NB 200.

Habe nach einigem suchen folgende Anleitung gefunden: http://dan.drydog.com/apache2php.html
Die Installation ist nun (von Apache, PHP kommt erst noch) komplett durch, allerdings lässt sich Apache nicht über
Code:
$ sudo ./httpd -k start
starten.

Die Fehlermeldung ist eigentlich eindeutig:
Zitat:
$ sudo ./httpd -k start
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Diese Fehlermeldung soll (nach selbstinterpretation und Google) bedeuten, dass der Port/Socket 80 belegt ist- doch laut
Code:
$ netstat
ist er das ganz und gar nicht- sämtliche aufgelisteten Dienste laufen über einen vierstelligen Socket, auch 0080 ist nicht dabei.

Wunderlich ist dazu, dass ich im Firefox unter "http://localhost/" bzw "http://localhost/index.html" die Default-Seite angezeigt bekomme (Inhalt der Seite siehe weiter unten). Ändere ich außerdem die Datei /usr/locale/apache/htdocs/index.html, so ändert sich an "http://localhost/index.html" nichts- zumal in der index.html im Dateiverzeichniss nur das allgemein bekannte "It Works" zu finden ist, und nicht der Zusatz.

Was kann schief gelaufen sein? Habe mehrfach nachgeschaut (per $ sudo ./httpd -k stop) und mein Netbook neugestartet, aber die Fehlermeldung kommt nach wie vor.


Gruß,
SargTeX




//Inhalt von "http://localhost/index.html" im Browser:
Zitat:
It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.
Mit Zitat antworten
 

Stichworte
apache, belegt, installation, kann nicht starten, socket 80


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind aus.
[IMG] Code ist aus.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +2. Es ist jetzt 14:59:52 Uhr.


Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.


© 2001-2020 E-Mail SELFPHP OHG, info@selfphp.deImpressumKontakt