PHP Forum

PHP Forum (http://www.selfphp.de/forum/index.php)
-   Off Topic Area (http://www.selfphp.de/forum/forumdisplay.php?f=15)
-   -   Shopsoftware gesucht (http://www.selfphp.de/forum/showthread.php?t=24943)

newbienchen 23.04.2013 15:36:19

Shopsoftware gesucht
 
Suche eine kostenlose Shopsoftware mit Downloadbereich. Kennt ihr das was???
Wusste nicht wo ich es posten soll hab einfach mal hier gemacht. Verkauft werden sollen Sportartikel. Habt ihr eine Idee?

meikel 23.04.2013 17:13:24

AW: Shopsoftware gesucht
 
Zitat:

Zitat von newbienchen (Beitrag 144893)
Suche eine kostenlose Shopsoftware mit Downloadbereich. Kennt ihr das was???

Was verstehst Du unter "Downloadbereich"?
Natürlich kennt der eine oder andere da was. Entscheidend ist, daß Du das Script verstehst und notfalls auch reparieren kannst. Da es um Geld geht, ist auch die Wahl des Bezahlsystems incl. des Anbieters (zB. Paypal, VISA) wichtig. Ebenfalls wichtig ist, daß der Shop im entscheidenden Moment SSL (Bestellung + Bezahlung) anbieten kann. Dazu gehört dann auch ein ordentliches Zertifikat.
Ebenfalls entscheidend ist auch die PHP Version. Bei den bekannt gewordenen Bugs ist alles gleich/kleiner 5.0.8 abzulehnen.
Zitat:

Wusste nicht wo ich es posten soll hab einfach mal hier gemacht.
Im off topic isses schon richtig.

sysop 24.04.2013 16:26:16

AW: Shopsoftware gesucht
 
http://www.modified-shop.org/

Ist auf einem relativ neuem Stand, kostenlos und den gesetzlichen Anforderungen gewachsen. Abgesehen davon wird der AShop ständig gewartet.

meikel 25.04.2013 00:27:19

AW: Shopsoftware gesucht
 
Zitat:

Zitat von sysop (Beitrag 144913)
Ist auf einem relativ neuem Stand,

Relativ? Hab mir zwei/drei Scripte angeguckt: PHP4 tauglich. Ab PHP 5.3.3 gibts Zoff. Ua. wegen fehlerhafter Konstruktoren.

Die Smarty Version 2.6.27 ist zu alt und fällt auf die Fresse, wenn das PHP nicht aus dem selben Museum stammt. "Smarty 3.1.13 Released" - det wär aktuell.

Ich wäre da zu faul, den Kram zu entwanzen...

sysop 25.04.2013 10:40:41

AW: Shopsoftware gesucht
 
Aha, bei mir läuft das hier auf PHP 5.4.4-14 Debian rund und keinerlei Fehler.
Seit 1.06 ist (zumindest lt. Webseite) PHP5 Voraussetzung.

Aber man lernt ja nie aus.

meikel 25.04.2013 15:55:40

AW: Shopsoftware gesucht
 
Zitat:

Zitat von sysop (Beitrag 144920)
Aha, bei mir läuft das hier auf PHP 5.4.4-14 Debian rund und keinerlei Fehler.

Debilian? Auch das noch...
Zitat:

Seit 1.06 ist (zumindest lt. Webseite) PHP5 Voraussetzung.
Sowas:
PHP-Code:

/**
     * The class constructor.
     */
    
function Smarty()
    {
      
$this->assign('SCRIPT_NAME', isset($_SERVER['SCRIPT_NAME']) ? $_SERVER['SCRIPT_NAME']
                    : @
$GLOBALS['HTTP_SERVER_VARS']['SCRIPT_NAME']);
    } 

ist PHP4. Die Abwärtskompatibilität zu PHP4 wurde (wenn ich mich nicht irre) mit PHP 5.3.3 geändert. Der Konstruktor muß dann so aussehen:
PHP-Code:

/**
     * The class constructor.
     */
    
function __construct()
    {
      
$this->assign('SCRIPT_NAME', isset($_SERVER['SCRIPT_NAME']) ? $_SERVER['SCRIPT_NAME']
                    : @
$GLOBALS['HTTP_SERVER_VARS']['SCRIPT_NAME']);
    } 

Wenn sich Dein PHP 5.4.14 darüber nicht aufgeregt hat, verwundert mich allerdings etwas... error_reporting(0) ?

Und das:
PHP-Code:

@$GLOBALS['HTTP_SERVER_VARS']['SCRIPT_NAME']); 

ist der Gipfel. Das ist PHP 4.0.4pl1.

Mich betrifft das weniger, weil ich den neuen Konstruktor schon seit PHP 5.0 verwende. Allerdings habe ich keine Lust, mir die anderen Files auch noch anzugucken.

Und das betrifft nicht nur das steinalte Smarty:
PHP-Code:

/*
   based on:
   (c) 2000-2001 The Exchange Project  (earlier name of osCommerce)
   (c) 2002-2003 osCommerce(currencies.php,v 1.15 2003/03/17); www.oscommerce.com
   (c) 2003 nextcommerce (currencies.php,v 1.9 2003/08/17); www.nextcommerce.org
   (c) 2006 XT-Commerce (xtcPrice.php 1316 2005-10-21) 
*/

/**
 * This class calculates and formates all prices within the shop frontend
 *
 */
class xtcPrice {

  var 
$currencies;
  
  
/**
   * Constructor initialises all required values like currencies, tax classes, tax zones etc.
   *
   * @param String $currency
   * @param Integer $cGroup
   * @return xtcPrice
   */
  
function xtcPrice($currency$cGroup) { 

Zitat:

(c) 2006 XT-Commerce (xtcPrice.php 1316 2005-10-21)
Is eben altes Zeuch... <ggg>

CookieMonster 21.08.2014 18:20:54

AW: Shopsoftware gesucht
 
Gibt doch auch inzwischen so Baukastensysteme von Internet-Anbietern, das wäre doch eine einfache Lösung.

Wisay1982 31.08.2014 22:51:46

AW: Shopsoftware gesucht
 
Also so Baukastensysteme davon halte ich rein gar nix. Damit handelt man sich nur Ärger ein und es funktioniert nachher nichtmal wie es soll. Würde ich die Finger von lassen.


Alle Zeitangaben in WEZ +2. Es ist jetzt 06:27:49 Uhr.

Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.