PHP Forum

PHP Forum (http://www.selfphp.de/forum/index.php)
-   Apache HTTP-Server (http://www.selfphp.de/forum/forumdisplay.php?f=23)
-   -   Installationsprobleme (http://www.selfphp.de/forum/showthread.php?t=22478)

SargTeX 25.11.2009 21:02:59

Installationsprobleme
 
Moin.

Versuche nun schon seit über 24h, Apache V 2.2.14 zu installieren. Sollte eigentlich kein Problem darstellen, da ich es unter Windows schon häufiger installiert und deinstalliert habe- mit PHP und MySQL.

Ich verwende nun als Betriebssystem Ubuntu 9.10 Netbook Remix auf einem Toshiba NB 200.

Habe nach einigem suchen folgende Anleitung gefunden: http://dan.drydog.com/apache2php.html
Die Installation ist nun (von Apache, PHP kommt erst noch) komplett durch, allerdings lässt sich Apache nicht über
Code:

$ sudo ./httpd -k start
starten.

Die Fehlermeldung ist eigentlich eindeutig:
Zitat:

$ sudo ./httpd -k start
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Diese Fehlermeldung soll (nach selbstinterpretation und Google) bedeuten, dass der Port/Socket 80 belegt ist- doch laut
Code:

$ netstat
ist er das ganz und gar nicht- sämtliche aufgelisteten Dienste laufen über einen vierstelligen Socket, auch 0080 ist nicht dabei.

Wunderlich ist dazu, dass ich im Firefox unter "http://localhost/" bzw "http://localhost/index.html" die Default-Seite angezeigt bekomme (Inhalt der Seite siehe weiter unten). Ändere ich außerdem die Datei /usr/locale/apache/htdocs/index.html, so ändert sich an "http://localhost/index.html" nichts- zumal in der index.html im Dateiverzeichniss nur das allgemein bekannte "It Works" zu finden ist, und nicht der Zusatz.

Was kann schief gelaufen sein? Habe mehrfach nachgeschaut (per $ sudo ./httpd -k stop) und mein Netbook neugestartet, aber die Fehlermeldung kommt nach wie vor.


Gruß,
SargTeX




//Inhalt von "http://localhost/index.html" im Browser:
Zitat:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

CPA 26.11.2009 10:39:33

AW: Installationsprobleme
 
Mhhh nur mal so am Rande.. Warum installierst den Apache mit PHP und MySQL nicht aus den Ubuntu-eigenen Repositorys?

Geht im übrigen am schnellsten:

Code:

sudo apt-get install apache2-mpm-prefork
sudo apt-get install libapache2-mod-php5
sudo apt-get install mysql-server php5-mysql

Nach dieser Art der Installation findest alle Konfigurationsdateien vom Apache im Verzeichnis "/etc/apache2".
Im Verzeichnis "/var/www" ist dann der Document-Root der Standard-Webseite.

Wird zusätzlich noch phpMyAdmin benötigt kann das ebenfalls mittels:
Code:

sudo apt-get install phpmyadmin
installiert werden.

SargTeX 26.11.2009 16:15:29

AW: Installationsprobleme
 
Thx :). Geht jetzt auch, bis auf ein Problem: Wenn ich localhost/index.php aufrufe (Datei habe ich kurz zuvor erstellt), wird mir die Datei zum Download angeboten.

Muss ich PHP erst manuell starten?
Wo befinden sich die Dateien von PHP und MySQL (Applikationsdateien)?

CPA 26.11.2009 23:21:45

AW: Installationsprobleme
 
Nö, du musst dem Apache mitteilen, dass er *.php-Dateien auch als PHP interpretiert.

Wenn du noch die Standardinstallation hast (so wie ich es dir gepostet habe), dann findest im Verzeichnis "/etc/apache2/sites-available" eine Datei "default".

Dort suchst du nach dem Abschnitt:
Code:

        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                DirectoryIndex index.php index.html index.htm
                AllowOverride All
                Order allow,deny
                allow from all
                Options +Indexes
        </Directory>

Sollte so ähnlich aussehen, wichtig ist die obere Zeile (<Directory /var/www/>).

Dort fügst folgendes ein:
Code:

                <IfModule mod_php5>
                            AddType application/x-httpd-php .php
                            php_flag magic_quotes_gpc Off
                            php_flag track_vars On
                            php_flag register_globals Off
                </IfModule>

Das Ganze sollte dann ungefähr so aussehen:
Code:

        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                DirectoryIndex index.php index.html index.htm
                AllowOverride All
                Order allow,deny
                allow from all
                Options +Indexes
                <IfModule mod_php5>
                            AddType application/x-httpd-php .php
                            php_flag magic_quotes_gpc Off
                            php_flag track_vars On
                            php_flag register_globals Off
                </IfModule>
        </Directory>

Zum Schluss die Datei speichern und den Apachen neu starten mittels:
Code:

/etc/init.d/apache2 restart

SargTeX 27.11.2009 15:47:36

AW: Installationsprobleme
 
Danke :).
Gehe ich richtig in der Annahme, dass die PHP-Konfigurationsdateien unter /etc/php5 (die php.ini unter /etc/php5/apache2) liegen, und die MySQL-Applikationsdateien unter /etc/mysql?
Können auch die Dateien von alten Installationen bei mir sein...

CPA 27.11.2009 16:56:09

AW: Installationsprobleme
 
Zitat:

Zitat von SargTeX (Beitrag 132712)
Danke :).
Gehe ich richtig in der Annahme, dass die PHP-Konfigurationsdateien unter /etc/php5 (die php.ini unter /etc/php5/apache2) liegen, und die MySQL-Applikationsdateien unter /etc/mysql?
Können auch die Dateien von alten Installationen bei mir sein...

Jepp, da liegst du schon richtig :)


Alle Zeitangaben in WEZ +2. Es ist jetzt 09:03:33 Uhr.

Powered by vBulletin® Version 3.8.3 (Deutsch)
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.