PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Font-Probleme mit imagettftext()


Tokii
04.03.2005, 20:56:50
Ich bin auf einem Linux/Debian (sarge) und habe heute ein Update der php4-Bibliothek bekommen. Seit dem funktioniert die imagettftext() nicht mehr.
Gibt es dort patent-rechtliche Probleme mit verschiedenen Fonts? Welche Fonts könnten eventuell noch funktionieren - oder haben sich bei imagettftext() andere Dinge geändert (Reihenfolge der Variablen o.ä.)?

Weiß irgend jemand was darüber?
(Ich habe diese Funktion vielfach verwendet - teilweise auch für Kunden...)

xabbuh
04.03.2005, 22:25:25
Seit dem funktioniert die imagettftext() nicht mehr.
Welche Fehlermeldung erhälst du denn?

Tokii
05.03.2005, 14:07:22
Im log steht: imagettftext(): Could not find/open font in "adresse".

An der Adresse und an den Zugriffsrechten hat sich aber nichts geändert...

|Coding
05.03.2005, 14:17:29
vieleicht ist deine font nicht kompatibel. ist das eine selbst erstellte? hast du es mal mit einer anderen versucht?

Tokii
05.03.2005, 14:27:33
Ich habe 7 verschiedene Fonts Lokal abgespeichert u.a arial, verdana, comic sans...
und bis gestern vormittag hat das alles funktioniert...

xabbuh
05.03.2005, 17:05:25
Tritt der Fehler nur mit einer Schrift oder mit allen auf?

Tokii
06.03.2005, 11:46:42
Bislang habe ich keinen Font gefunden, bei dem der Fehler nicht auftritt :(

Zwischenzeitlich habe ich auch weitere Fehlermeldungen im Log erhalten:
1. gd-png: fatal libpng error: Invalid muber of colors in palette
(... ich benutze in dem Bild 5 rgb-Farben)

2. gd-png error: setjmp returns error condition

Tokii
06.03.2005, 12:16:31
1. gd-png: fatal libpng error: Invalid muber of colors in palette
(... ich benutze in dem Bild 5 rgb-Farben)

2. gd-png error: setjmp returns error condition

...beide Fehler tauchen auch auf, wenn ich nur mit schwarz/weiss arbeite...

xabbuh
06.03.2005, 14:28:52
Welche Versionen von PHP und GD hast du jetzt am Laufen? Ist beim konfigurieren dieser vielleicht ein Fehler aufgetreten?

Tokii
06.03.2005, 19:34:56
php Version 4:4.3.10-8
php4-gd ebenso
libgd2 Version 2.0.33-1.1

upgrade mit apt-get;
es ist dabei keine Abfrage wg. Änderung persönlicher Einstellungen gelaufen.