PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : php Problem nach update der Apache Version auf SSL


travelfreak
04.02.2005, 19:13:17
Hi,

ich habe eine Apache Version 1.3.29 auf die Version 1.3.33
upgedatet. Es war diese Version: http://hunter.campbus.com/
Ich will den Apache SSL fähig machen.

Wenn ich den Apache nach dem Update starte bekomme ich von
PHP folgendw Warnmeldung zurück:

C:apachebatchs>c:/apache/apache.exe
[Fri Feb 04 18:14:06 2005] [warn] Loaded DSO c:/apache/php/php4apache.dll uses p lain Apache 1.3 API, this module might crash under EAPI! (please recompile it wi th -DEAPI) Apache/1.3.29 (Win32) PHP/4.3.4 running...

Kann mir hier einer helfen. ISt diese Meldung ernstzunehmen ?
Manche sagen, der Apache läuft trotzdem seit Monaten, andere sagen,
auf einem Testsystem ists OK (ist aber Produktivsystem) andere haben eine neue PHP Version kompiliert. Dies hab ich aber noch nie
gemacht (unter Windows).

Könnte ich meinen Apache auch SSL fähig machen wenn ich folgendes mache, oder würde dass so nicht funktionieren:
ich kopiere ssl_mod.so in Modules und passe den Pfad in der conf entsprechend an. Anschliessend noch die 2 Dlls kopieren libeay32.dll und libssl32.dll und fertig.

Besten Dank für die Hilfe,
Gruß
Marcus

xabbuh
23.02.2005, 18:41:13
Vielleicht hilft dir das weiter: http://forum.de.selfhtml.org/archiv/2003/3/t41193/