PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : virueller Host leitet favicon.ico an falsche Stelle


mali
15.06.2005, 11:22:32
Hallo,

ich hab bei mir zwei virtuelle Hosts am laufen, die ich in einer vhost.conf konfiguriere, die wiederum in der httpd.conf über include eingebunden wird.
Ich weiss, dass der erste virtuelle Host der "allgemeine" ist, bei dem die Anfragen landen, wenn die nachfolgenden nun nicht treffen (ServerName).
Ich betreibe sie namensbasiert.
Im Weiteren nenne ich sie einmal bla1.de und bla2.de

Jetzt zu meinem Problem: Wenn ich http://bla2.de aufrufe lande ich wunderbar bei dem richtigen Host. Allerdings wird mir das favicon.ico von bla1.de angezeigt.
Ich habe dann mal testweise http://bla2.de/favicon.ico eingegeben und bin auch dort bei bla1.de gelandet. Dann habe ich einmal http://bla2.de/index.html eingegeben und lande auch dort bei bla1.de.

Sobald ich also etwas an die Url dranhänge, lande ich bei dem falschen virtuellen Host. Dachte mir dann, ich bring mal noch ein ServerAlias bla2.de/* rein - brachte aber auch nichts.

Weiss jetzt wirklich nicht mehr weiter...

meine vhost.conf sieht so aus:

NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin bla@bla1.de
ServerName bla1.de
DocumentRoot /srv/www/htdocs/bla1
ErrorLog /var/log/apache2/error_log
CustomLog /var/log/apache2/access_log combined
HostnameLookups Off
UseCanonicalName On
ServerSignature On
Include /etc/apache2/conf.d/*.conf
<IfModule mod_userdir.c>
UserDir public_html
Include /etc/apache2/mod_userdir.conf
</IfModule>
<Directory "/srv/www/htdocs/bla1">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
DirectoryIndex index.html
</VirtualHost>

<VirtualHost *:80>
ServerAdmin bla@bla2.de
ServerName bla2.de
ServerAlias bla2.de/*
DocumentRoot /srv/www/htdocs/bla2
ErrorLog /var/log/apache2/bla2-error_log
CustomLog /var/log/apache2/bla2-access_log combined
HostnameLookups Off
UseCanonicalName On
ServerSignature On
Include /etc/apache2/conf.d/*.conf
<IfModule mod_userdir.c>
UserDir public_html
Include /etc/apache2/mod_userdir.conf
</IfModule>
<Directory "/srv/www/htdocs/bla2">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
DirectoryIndex index.html
</VirtualHost>


Schon mal Danke für die Hilfe...